Project

General

Profile

Actions

New Model #10648

closed

Support for Baofeng UV-17 Pro GPS radio (and related models UV-18/19/20/21/22)

Added by Terri Kennedy 10 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
06/17/2023
Due date:
% Done:

100%

Estimated time:
Equipment Loan/Gift Offered:
Yes
I read the instructions above:
Yes

Description

The Baofeng UV-17 Pro GPS is a newly-released model which has generated quite a bit of interest / discussion on the Facebook Baofeng Owner's Club group. It appears to be a new direction for Baofeng designs, using a full-color screen with full bitmap display. The firmware is apparently flashable, although neither the firmware or the flash utility has surfaced yet.

A manual for a similar model (UV-17P) has been released on various international Baofeng sites and is available from the Facebook group. The CPS 1.2.4 software (which has a dropdown allowing you to select from any of a number of new models in this series) is available at Miklor. Hopefully this means that a number of models can be supported with relative ease after the first one is added to CHIRP.

I can provide two radios for development, and leave one with you long-term for testing of new CHIRP releases. Note that I'm just a radio owner, not a distributor, etc. Others have also said they are willing to loan radios for development, but I'm definitely committing to doing so if needed.

I have made some progress decoding the CPS .dat format for the UV-17 Pro GPS which I can also make available if desired.

Sample AliExpress listing for this radio: https://www.aliexpress.us/item/3256805188334196.html


Files

Baofeng_UV-17Pro_20230601(factory #1).img (52.3 KB) Baofeng_UV-17Pro_20230601(factory #1).img Jim Unroe, 08/23/2023 06:58 PM
Baofeng_UV-17Pro_20230824.dat (86.5 KB) Baofeng_UV-17Pro_20230824.dat Factory *.dat Jim Unroe, 08/24/2023 01:29 PM
Baofeng_UV-17Pro_20230824.img (52.3 KB) Baofeng_UV-17Pro_20230824.img Factory *.img Jim Unroe, 08/24/2023 01:30 PM
Baofeng_UV-17Pro_20230824.txt (270 KB) Baofeng_UV-17Pro_20230824.txt Serial port capture Jim Unroe, 08/24/2023 01:30 PM
Default UV-17R (non PRO non GPS) HWv01 FWv1.11.dat (76.3 KB) Default UV-17R (non PRO non GPS) HWv01 FWv1.11.dat John L, 09/23/2023 11:14 AM
baofeng_uv17Pro.py (48 KB) baofeng_uv17Pro.py Sander van der Wel, 09/25/2023 05:20 AM
baofeng_uv17Pro.py (48 KB) baofeng_uv17Pro.py Sander van der Wel, 09/25/2023 03:41 PM
baofeng_uv17Pro.py (51.4 KB) baofeng_uv17Pro.py Sander van der Wel, 09/26/2023 09:20 AM
baofeng_uv17Pro.py (40.1 KB) baofeng_uv17Pro.py Added DTMF and VFO settings Sander van der Wel, 10/06/2023 01:31 PM
baofeng_uv17Pro.py (54.8 KB) baofeng_uv17Pro.py Added all the basic settings and renamed the setting tabs Sander van der Wel, 10/17/2023 01:59 PM
baofeng_uv17Pro.py (54.8 KB) baofeng_uv17Pro.py Sander van der Wel, 10/17/2023 10:48 PM
chirp-11-16-23.jpg (33.3 KB) chirp-11-16-23.jpg Russell Leu, 11/16/2023 11:01 AM
clipboard-202311162135-msyy2.png (6.28 KB) clipboard-202311162135-msyy2.png VIOREL LUNGU, 11/16/2023 11:35 AM
baofeng_uv17Pro.py (54.8 KB) baofeng_uv17Pro.py Sander van der Wel, 11/16/2023 12:05 PM
clipboard-202311162248-sgh5h.png (14.8 KB) clipboard-202311162248-sgh5h.png VIOREL LUNGU, 11/16/2023 12:48 PM
baofeng_uv17Pro.py (55.9 KB) baofeng_uv17Pro.py Latest driver staged for pull request into chirp Sander van der Wel, 11/17/2023 04:49 AM
baofeng_uv17Pro.py (49.5 KB) baofeng_uv17Pro.py Driver staged for implementing in Chirp Sander van der Wel, 11/17/2023 11:59 PM

Related issues

Related to New Model #10633: Baofeng UV-17 (non GPS version)New06/12/2023

Actions
Actions #1

Updated by Dan Smith 10 months ago

Actions #2

Updated by Jim Unroe 8 months ago

For anyone interested, here is the CHIRP Radio Images (*.img) file that I captured from my UV-17 Pro GPS.

Actions #3

Updated by Jim Unroe 8 months ago

As requested, the attached files were just captured from my UV-17Pro GPS that is still in its original factory state.

Actions #4

Updated by Louis Wise 8 months ago

I have a BF-18H which must be a UV-18 as the CPS for the UV-18 radio works for it. I just use the drop down for the UV in the 1.2.4 CPS. I am willing to loan my radio for Chrip development if needed. I would hope that a Chrip version could work on all of these 5 radios models!

Actions #5

Updated by Ronald Donato 8 months ago

Jim Unroe wrote in #note-3:

As requested, the attached files were just captured from my UV-17Pro GPS that is still in its original factory state.

so, what radio would I select in the Baofeng drop down list?

Actions #6

Updated by Jim Unroe 8 months ago

Ronald Donato wrote in #note-5:

Jim Unroe wrote in #note-3:

As requested, the attached files were just captured from my UV-17Pro GPS that is still in its original factory state.

so, what radio would I select in the Baofeng drop down list?

None. The UV-17Pro GPS isn't supported by CHIRP.

Actions #7

Updated by John L 7 months ago

I would also appreciate CHIRP support of the UV-17 series radios.

To support this effort, attached is a stock UV-17R .dat file (NON-PRO NON-GPS) pulled from a brand new UV-17R.
This .dat file is pulled from a radio indicating Firmware: V1.11, Hardware: V01.
This is shown on https://www.miklor.com/UV17pro/Various%20Models.php as the "Basic UV-17 (new)" with the white text on Black background.
This was pulled using the "T6UV v1.1.8" codeplug software (CPS).

Actions #8

Updated by Sander van der Wel 7 months ago

I am building a driver for this radio. At the moment it only supports the channels and not the radio settings.
There might still be some bugs. Do better backup your channels with cps, before using it.
This is my first driver for Chirp.

Actions #9

Updated by John L 7 months ago

Sander, this is great.
I can confirm that your baofeng_uv17Pro.py module also works with my UV-17R basic model running FWv1.11.
It is able to read/write/edit.

Actions #10

Updated by Sander van der Wel 7 months ago

Yes it supports the Pro GPS version and the UV17R/L/Pro (whatever they call it..), version with the color screen, black background, white characters version. :-)

Actions #11

Updated by Sander van der Wel 7 months ago

I was missing a couple of bytes in the configuration dump.
These are essential for editing bank names, which I am working on now.

Images made with the previous driver, are not compatible with this one.

Actions #12

Updated by Sander van der Wel 7 months ago

I have added support for the bank names. You can find them in settings -> other

Actions #13

Updated by Paul Robinson 7 months ago

Well done! I was having a poke at this one as well, but miss-placed my programming cable. Was stumped with the encryption and just wondering how you figured it out? Mines badged a UV17 Pro V2, but looking at the code, the programming sequence seems the same so I assume it'll work (i'll confirm if I can find my cable again).

Actions #14

Updated by Sander van der Wel 7 months ago

Added support for DTMF and VFO in the settings. The configuration file did become bigger, so it is incompatible with previous img files.

Actions #15

Updated by Matteo Fabbroni 6 months ago

This is working with Baofeng 18 i-Black Pro Max!

Actions #16

Updated by Sander van der Wel 6 months ago

I've added all the available settings for the radio. It still needs full testing. So please let me know how this works for you!!

Actions #17

Updated by Sander van der Wel 6 months ago

I fixed a bug in the "Send ID delay", setting (which is also a bug in CPS) and in "Menu quit timer"

Actions #18

Updated by Matteo Fabbroni 6 months ago

I confirm that the driver works with Baofeng UV 18 i-black Pro Max.
I will try changing all settings and write them to have a full test. Only bank's page's blank, but I suppose this model do not support them, thus it's expected.
Further details after the test; by now super thanks! :D

Actions #19

Updated by Russell Leu 6 months ago

Confirmed working for UV-17Pro Basic (Black Background on display) https://www.miklor.com/UV17pro/Various%20Models.php

Actions #20

Updated by Russell Leu 6 months ago

Unable to communicate with UV-17 Basic, older model with blue background. https://www.miklor.com/UV17pro/Various%20Models.php

Actions #21

Updated by Sander van der Wel 6 months ago

@Russell Leu, try the driver at issue 10865, for the older model.

Actions #22

Updated by Juan Javier 6 months ago

Any program to modify the firmware of the uv-17 pro....can the findware be updated the same as the quan sheng equipment? ****

Actions #23

Updated by Seth Torkko 6 months ago

Sander van der Wel wrote in #note-17:

I fixed a bug in the "Send ID delay", setting (which is also a bug in CPS) and in "Menu quit timer"

I have both a UV-17L and the UV-17 Pro GPS and your module reads from both of them. Well done so far!

Actions #24

Updated by Jeff Khoury 6 months ago

Can confirm working on UV-17L. I have the UV-17M model on order, which has additional receive band in the 300MHz range, and a voice scrambler. When it arrives I will test and may take a crack at adding support for it to the contributed module.

Actions #25

Updated by Russell Leu 5 months ago

Now not working on UV-17R Black Background Screen after updating Chirp to 20231108 build and Python file dated 10/17/23. Radio downloads but the Memories area empty and shaded red, see attachment.

Actions #26

Updated by Russell Leu 5 months ago

Adding - when you hover over the red is displays "can only concatenate str(not "bytes") to str"

Actions #27

Updated by VIOREL LUNGU 5 months ago

CHIRP version: chirp-next-20231108-win64
Radio: UV17 Pro GPS

The application throws this type of error in the log (chirp_debug-xw2hk81d.txt):

[2023-11-15 01:06:13,110] chirp.wxui.common - ERROR: Failed to run get_memory(999, )
Traceback (most recent call last):
File "chirp\wxui\common.py", line 280, in do_radio
File "E:\SDRadio\Baofeng UV-17 Pro GPS\CHIRP module from issue 10648\baofeng_uv17Pro.py", line 1320, in get_memory
if self._is_txinh(_mem):
File "E:\SDRadio\Baofeng UV-17 Pro GPS\CHIRP module from issue 10648\baofeng_uv17Pro.py", line 1301, in _is_txinh
raw_tx += _mem.txfreq[i].get_raw()
TypeError: can only concatenate str (not "bytes") to str
[2023-11-15 01:06:13,110] chirp.wxui.memedit - ERROR: Failed to load memory 999 as error because: can only concatenate str (not "bytes") to str

Actions #28

Updated by VIOREL LUNGU 5 months ago

Apologies, I missed the first 2 lines:

TypeError: can only concatenate str (not "bytes") to str
[2023-11-15 01:06:13,110] chirp.wxui.memedit - ERROR: Failed to load memory 998 as error because: can only concatenate str (not "bytes") to str
[2023-11-15 01:06:13,110] chirp.wxui.common - ERROR: Failed to run get_memory(999, )
Traceback (most recent call last):
File "chirp\wxui\common.py", line 280, in do_radio
File "E:\SDRadio\Baofeng UV-17 Pro GPS\CHIRP module from issue 10648\baofeng_uv17Pro.py", line 1320, in get_memory
if self._is_txinh(_mem):
File "E:\SDRadio\Baofeng UV-17 Pro GPS\CHIRP module from issue 10648\baofeng_uv17Pro.py", line 1301, in _is_txinh
raw_tx += _mem.txfreq[i].get_raw()
TypeError: can only concatenate str (not "bytes") to str
[2023-11-15 01:06:13,110] chirp.wxui.memedit - ERROR: Failed to load memory 999 as error because: can only concatenate str (not "bytes") to str

Actions #29

Updated by Dan Smith 5 months ago

  • I read the instructions above set to Yes

Yep, this is a result of a recent change in the CHIRP core code which returns bytes instead of str from get_raw() calls. The author will need to fix that in the driver.

Sander, I assume there is a plan to submit this for inclusion in chirp itself right?

Actions #30

Updated by Sander van der Wel 5 months ago

I modified the driver so it works with the latest changes in Chirp.

Daniel Fiechter:
How do I submit this driver for inclusion in Chirp? Git pull request?

Actions #31

Updated by Dan Smith 5 months ago

I assume that was directed at me, but yes: https://github.com/kk7ds/chirp

Actions #32

Updated by VIOREL LUNGU 5 months ago

Issue sorted with the latest version:

Actions #33

Updated by Jason Piper 5 months ago

Can I drop this file into the Windows filesystem anywhere to test? Or does it require an application update? I just unpacked my UV-17R Non-GPS and wanted to give it a run!

Actions #34

Updated by Dan Smith 5 months ago

Actions #35

Updated by Jason Piper 5 months ago

Thanks Dan!!

Just tested, did a full backup from CPS and then did a stock download file for backup.

Grabbed a copy of my F8HP channel list and did a copy/paste just to see if it'd work.

Happy to report is was FLAWLESS and worked straight away ! Nice work on this!

Actions #36

Updated by Sander van der Wel 5 months ago

@kkds I am working on passing all the tests for a pull request. Still some work to do. :-)

Actions #37

Updated by Sander van der Wel 5 months ago

Dan Smith I have opened a pull request, but I have no clue on how to pass the "create support matrix" test and the "check commit" test.

Could you offer me some help?

Actions #38

Updated by Dan Smith 5 months ago

We can discuss that stuff on the PR itself. The instructions for makesupported are in the PR instructions and if you view the fails of the PR checks it should be obvious. I'll review after work and make some comments (there).

Actions #39

Updated by Sander van der Wel 5 months ago

I have added the driver which is currently staged for implementing in Chirp.

Actions #40

Updated by Dan Smith 5 months ago

  • Status changed from New to Closed
  • Assignee set to Sander van der Wel
  • Target version set to chirp-py3
  • % Done changed from 0 to 100

This is merged now.

Sander, I forgot to check but next time put something like "Fixes #10648" in the commit message and it will tie the commit to the bug and close it here as completed as soon as it merges.

Also it looks like maybe there are some other duplicate issues for the UV-17? If you get a chance, you can link those here and mark those as closed as well. You should have permissions to do that now.

Thanks!

Actions

Also available in: Atom PDF