Project

General

Profile

Actions

New Model #7209

closed

ABBREE AR-F8

Added by Capt. Willy over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
09/12/2019
Due date:
% Done:

0%

Estimated time:
Equipment Loan/Gift Offered:
No
I read the instructions above:

Description

Love to see the Abbree AR-F8 added to CHIRP. Interesting and powerful device with 999 memories and GPS.

Definitely need the CHIRP magic to tame this beastie!

Thanks.


Related issues

Is duplicate of New Model #7065: ABBREE AR-F8Closed09/12/2019

Actions
Has duplicate New Model #7589: Abbree AR-F8Closed01/21/2020

Actions
Actions

Also available in: Atom PDF