Project

General

Profile

Actions

New Model #9793

closed

Baofeng UV-13 PRO

Added by Cameron Moyer about 2 years ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
-
Start date:
03/19/2022
Due date:
% Done:

0%

Estimated time:
Equipment Loan/Gift Offered:
No
I read the instructions above:
Yes

Description

Looking for a CPS or to incorporate this radio into CHIRP. I got mine from AliExpress, but can be found on various sites.

You can view some specs and what it looks like here:

https://www.hi-radio.com/product/baofeng-uv-13-pro-walkie-talkie-10w-uhf-vhf-dual-band-two-way-radio/

Any help is appreciated!


Files

radiotrace (185 KB) radiotrace William BENHARBONE, 09/30/2022 07:31 AM
UV13-Firmware-V06.01.013-20211104_01013.bin (57.7 KB) UV13-Firmware-V06.01.013-20211104_01013.bin Aaron Blankenship, 04/06/2023 05:17 AM
UV-13 Pro V2 Default.data (48 KB) UV-13 Pro V2 Default.data Gary G, 12/04/2023 01:16 AM
Baofeng_UV-9R_GB7RY-No PMR.img (8.73 KB) Baofeng_UV-9R_GB7RY-No PMR.img Gary G, 12/04/2023 01:23 AM
debug.log (37.9 KB) debug.log Daniel Personale, 02/09/2024 04:58 PM
baofeng_uv17.py (13.1 KB) baofeng_uv17.py 88598f92 base Dan Smith, 02/09/2024 06:45 PM
baofeng_uv17Pro.py (36.1 KB) baofeng_uv17Pro.py 88598f92 pro Dan Smith, 02/09/2024 06:45 PM
chirp_debug-r0z_q8wf-broken.txt (5.58 KB) chirp_debug-r0z_q8wf-broken.txt Not working device Nils W, 02/10/2024 04:10 AM
chirp_debug-8kkak7fy-working.txt (310 KB) chirp_debug-8kkak7fy-working.txt Working device Nils W, 02/10/2024 04:10 AM
IMG_20240214_092024.jpg (693 KB) IMG_20240214_092024.jpg Cristofer Fuentealba, 02/14/2024 04:49 AM
chirp.log (277 KB) chirp.log Rot Ulet, 02/14/2024 09:14 AM
Baofeng_UV-13Pro_20240214(factory #1).img (36.2 KB) Baofeng_UV-13Pro_20240214(factory #1).img Jim Unroe, 02/14/2024 11:41 AM

Related issues

Related to New Model #10099: Baofeng UV-13 Pro 999 channels Closed10/24/2022

Actions
Related to Bug #11167: Trouble with UV-13Pro after uploadClosedSander van der Wel02/14/2024

Actions
Has duplicate New Model #10008: UV-13 PRO V2 999 CHANNELS not supported by CHIRP ? Closed08/28/2022

Actions
Actions #1

Updated by Jim Unroe about 2 years ago

  • Status changed from New to Feedback

I would expect that the programming software for the P15UV would work for your radio. It works for my UV-15R. The "P15UV":https://fccid.io/2AJGM-P15UV/Users-Manual/User-Manual-5201622 appears to be the model that all of these variants (UV-13 Pro, UV-15R, etc) seem to be based upon. This particular CPS is available from the ABBREE website's "download pages":https://www.abbree.cn/download/. For additional information regarding support these radio variants, you may want to follow issue #9429 (which this is issue technically a duplicate of).

My personal policy is to never purchase any radio until after I have physical possession of the OEM software.

Jim KC9HI

Actions #2

Updated by Jim Winicky about 2 years ago

If it would help I would be willing to load my radio (UV-13Pro) for development. Or with some coaching I could probably do the data exports needed.

Actions #3

Updated by Boris K about 2 years ago

The OEM software is fine, but not as good as Chirp. Any development being done?

Actions #4

Updated by Jim Winicky almost 2 years ago

I am willing to Loan my uv13 pro or learn how to provide the output with a little coaching.

Hardware loan is hereby offered

Actions #5

Updated by Jim Unroe almost 2 years ago

I would suggest that you monitor issue #9237. I believe that the Radioddity GM-30 and Baofeng UV-13 Pro and UV-15R are very close cousins. That is what I am doing.

Jim KC9HI

Actions #6

Updated by Jim Winicky almost 2 years ago

GM13 USES SAME CHASSIS SAM AS RT95, TYT UV88, TIDRADIO H5 (GMRS). NOT SURE IF SOFTWARE IS SAME.
THE UV88 IS MUCH CLOSER TO THE GM30 AND THE RADIODITY RT85 IS DEAD RINGER. BUT THOSE SOFTWARE DOES NOT WORK WITH UV13PRO AS FAR AS I CAN TELL

Actions #7

Updated by Sandrina Pereira almost 2 years ago

This software works with UV-13 Pro - http://download.abbree.com/P15UV%20CPS.rar

Actions #8

Updated by Jim Winicky almost 2 years ago

Still Willing to load Radio or figure out how to extract data from it uv-13 Pro.

Actions #9

Updated by William BENHARBONE over 1 year ago

communication between uv13pro and the http://download.abbree.com/P15UV%20CPS.rar software in radiotrace file

Actions #10

Updated by Valerio Corsaro over 1 year ago

William BENHARBONE wrote:

communication between uv13pro and the http://download.abbree.com/P15UV%20CPS.rar software in radiotrace file

Sorry i can't open the link and i am really struggling to find a software to program my uv 13 pro v2, any help?

Actions #11

Updated by Bernhard Hailer over 1 year ago

  • Has duplicate New Model #10008: UV-13 PRO V2 999 CHANNELS not supported by CHIRP ? added
Actions #12

Updated by Bernhard Hailer over 1 year ago

Actions #13

Updated by Cameron Moyer over 1 year ago

Jim Winicky wrote in #note-8:

Still Willing to load Radio or figure out how to extract data from it uv-13 Pro.

William BENHARBONE wrote in #note-9:

communication between uv13pro and the http://download.abbree.com/P15UV%20CPS.rar software in radiotrace file

Hi William. I did find 2 programs that allow programming of the radio. I uploaded a zip and rar file of each on my Dropbox. Hopefully this helps everyone when the abree link is down and while we still wait for chirp support.

https://drive.google.com/drive/folders/1FM9Qkyw1hG1hp80oJYLXwrPaqnGLLcS-

Actions #14

Updated by Cameron Moyer over 1 year ago

Cameron Moyer wrote in #note-13:

Jim Winicky wrote in #note-8:

Still Willing to load Radio or figure out how to extract data from it uv-13 Pro.

William BENHARBONE wrote in #note-9:

communication between uv13pro and the http://download.abbree.com/P15UV%20CPS.rar software in radiotrace file

Hi William. I did find 2 programs that allow programming of the radio. I uploaded a zip and rar file of each on my Google Drive. Hopefully this helps everyone when the abree link is down and while we still wait for chirp support.

https://drive.google.com/drive/folders/1FM9Qkyw1hG1hp80oJYLXwrPaqnGLLcS-

Actions #15

Updated by Alexandru Barbur over 1 year ago

Linking GM-30 related work in https://chirp.danplanet.com/issues/9237

Actions #16

Updated by Frank Rizzo over 1 year ago

Has anyone been able to get the gm30ctl.py module for the Radioddity GM-30 to work with the UV-13 Pro v2? [[[https://chirp.danplanet.com/attachments/7883]]]

Actions #17

Updated by Aaron Blankenship about 1 year ago

Abbree support has provided me with the UV-13 firmware V06.01.013 (attached) to support the TP-8Plus. Firmware can be flashed following the process on https://www.radioddity.com/blogs/all/how-to-update-radioddity-gm-30-firmware

The CPS 1.09 software without the GM-30 restrictions can also be found via Radioddity site via the European model GA-5E. https://www.radioddity.com/pages/radioddity-download

Actions #18

Updated by Freek Wolsink about 1 year ago

Thanks Aaron P Blankenships :) Big step :)

Actions #19

Updated by Freek Wolsink about 1 year ago

Freek Wolsink wrote in #note-18:

Thanks @AaronBlankenships :) Big step :)

Actions #20

Updated by Richard Wonka about 1 year ago

Aaron Blankenship wrote in #note-17:

Abbree support has provided me with the UV-13 firmware V06.01.013 (attached) to support the TP-8Plus. Firmware can be flashed following the process […]

The GM-30 software refuses to work with my baofeng-branded unit, but I have a working copy of the software labelled P15UV.

  • do you know if I can install this firmware on the baofeng UV-13 Pro (and not brick it)?
  • Not sure what TP-8Plus is; is a Firmware upgrade likely to improve things for my radio?

  • is a firmware upgrade to this binary beneficial

Actions #21

Updated by Richard Wonka about 1 year ago

Richard Wonka wrote in #note-20:

  • Not sure what TP-8Plus is; is a Firmware upgrade likely to improve things for my radio?

Ah… TP8plus is yet another label for the same thing it seems.

I wonder if a firmware upgrade will be worth it. Guess I’ll find out. For science.

Actions #22

Updated by slick . about 1 year ago

I have the paper manual that came with Baofeng branded HT. On the first page it says that the manual applies to UV-13Pro, TP8, TP8Plus, TP8R, TP8S, TP8X and PT8Pro.

Actions #23

Updated by Johnny Crabtree 6 months ago

With the latest version of CHIRPNext, this is working if you use the Baofeng UV-17 radio. It reads and writes to the radio.

Actions #24

Updated by Gary G 6 months ago

Hello New to this..... But wanting to help resolve UV-13 issue.
Purchased a UV-13 Pro V2 via Aliexpress - Using mentioned P15UV CPS in #1 link, I have attached a clean default image of radio - in hopes this will aid/help CHIRP team :)
While looking at this rig I looked for uv-T8 rig listing= not found then I tried UV-17, this managed to read my UV-13 which worked. I populated the memory channels list with my standard layout (from a UV-9R +) and was able to write this back to the UV-13 (I stress - Do this at your own risk).
The radio accepted the write 1st time - I pasted into memory 1 up to 102 - after rig reboot - memory 1 not shown. mem 2 onwards = larger font 3 decimal places shown eg 144.525 not 144.5250

As mentioned I hope this info helps. Note to Chirp team if I can be of further help / testing please ask. 73

Actions #25

Updated by Daniel Personale 4 months ago

I was able to connect my uv13-pro v2 using uv-17 in chirp.
From 20240130 version, i can't connect it, appear a message and radio reboot

Actions #26

Updated by Dan Smith 4 months ago

  • I read the instructions above set to Yes

I was able to connect my uv13-pro v2 using uv-17 in chirp.
From 20240130 version, i can't connect it, appear a message and radio reboot

There's nothing we can do for you without a debug log, so please capture and attach. How_To_Report_Issues

Actions #27

Updated by Daniel Personale 4 months ago

Dan Smith wrote in #note-26:

I was able to connect my uv13-pro v2 using uv-17 in chirp.
From 20240130 version, i can't connect it, appear a message and radio reboot

There's nothing we can do for you without a debug log, so please capture and attach. How_To_Report_Issues

Right...My bad. I've tried different baud-rate too, without success.

Actions #28

Updated by Dan Smith 4 months ago

Okay, I'm not sure if that's what other people are seeing here or not, but your debug log shows what you'd expect from a almost-but-not-quite-the-same model. Chirp is expecting more memory than the radio is sending, which is why it fails.

Were you saying that it worked before the 0130 version? If not, then I think that's expected. If it used to work and doesn't now, then maybe there's something that can be done, but I don't see anything in the history since then that makes me think it could be related.

Actions #29

Updated by Daniel Personale 4 months ago

Dan Smith wrote in #note-28:

Okay, I'm not sure if that's what other people are seeing here or not, but your debug log shows what you'd expect from a almost-but-not-quite-the-same model. Chirp is expecting more memory than the radio is sending, which is why it fails.

Were you saying that it worked before the 0130 version? If not, then I think that's expected. If it used to work and doesn't now, then maybe there's something that can be done, but I don't see anything in the history since then that makes me think it could be related.

Yep, it worked before that version

Actions #30

Updated by Dan Smith 4 months ago

Okay, perhaps it's Sander van der Wel 's revision:88598f9211ef8c0adc0695b43bfea13cd9ed4a7b . Maybe he will see this and comment.

I've attached the driver as it was before then. Please try loading these by first loading the uv17 and then the uv17pro modules (in that order) using LoadingTestModules as the procedure. See if that restores it to working. Please grab another debug log after you load and test.

TBH, I'm not sure why that change would cause your error, but it's related. Perhaps Sander will know.

Actions #31

Updated by Nils W 4 months ago

I am on version 20240208 and it seems that I have to play around with SNYC, VFO/Channel Mode, and VFO-Frequency to get my two UV-13 Pro v2 to pair with chirp.

A completely new device would not sync until I switched it to VFO and changed the carrier frequency a bit. Afterwards it would ync.

A device I could sync would stop syncing after enabling "SYNC" and playing around with the channels that I programmed. After disabling "SYNC", switching to VFO and again playing around with the carrier frequency, it started working again.

I've attached two log files, one of each scenario.

Actions #32

Updated by Sander van der Wel 4 months ago

I will have a look at this. Only difficult thing here is that I don't own this specific radio.

Actions #33

Updated by Sander van der Wel 4 months ago

I think what happened here, is that an upload of an image got interrupted. This can cause the memory map of the radio to corrupt. This makes it impossible for Chirp to find the right memory blocks. You can fix this by writing a working image to the radio.

I see someone already posted a default CPS image. Try writing that image to you radio and let me know if you can use Chirp again to read the radio.

Actions #34

Updated by Daniel Personale 4 months ago

Sander van der Wel wrote in #note-33:

I think what happened here, is that an upload of an image got interrupted. This can cause the memory map of the radio to corrupt. This makes it impossible for Chirp to find the right memory blocks. You can fix this by writing a working image to the radio.

I see someone already posted a default CPS image. Try writing that image to you radio and let me know if you can use Chirp again to read the radio.

I can confirm. I just tried.
Writing a previously saved .img file via Chirp to the radio, works.
What happened to me is: I had used chirp to save my frequencies. Then I used the Baofeng program to edit the "character problems", and wrote with that software. From here, if I try to reconnect to the radio with chirp, the message from yesterday appears. So I think it's an incompatibility between one program and another.

Actions #35

Updated by Dan Smith 4 months ago

I think that means we're interpreting this section incorrectly and probably need to fix something. At the least, I think we should be catching that error and warning the user with a more reasonable error message.

Does this mean we should mark the UV-13 Pro as identical to one of the UV-17 models, or perhaps subclass it so we have room to account for differences later?

Actions #36

Updated by Sander van der Wel 4 months ago

I want to try to fix this problem as good as possible. Since bricking my radio just for testing this problem, is not my hobby, I created an emulator that will act like the radio for both CPS and Chirp. :-) Just finished the emulator for the UV17 kind of models. It does look like we can mark the UV-13 Pro as a subclass. But we need some verification by someone who owns the 13 Pro.

Actions #37

Updated by Dan Smith 4 months ago

Sander, if you want to submit that to tools/ for posterity that's cool. I have an icom simulator that I use locally that I should put in there as well.

Actions #38

Updated by Sander van der Wel 4 months ago

  • Status changed from Feedback to Closed

The driver has been updated. An error will show if the memory is corrupted. And it is possible to upload a backup image to fix corrupted memory.

The UV-13Pro has been added as a supported radio.

Actions #39

Updated by Cristofer Fuentealba 4 months ago

I had problems creating a backup copy of my uv-13 pro, the memory was corrupted, I am using the latest version of chirp, does anyone have a backup copy of this device?

Actions #40

Updated by Jim Unroe 4 months ago

Cristofer Fuentealba wrote in #note-39:

I had problems creating a backup copy of my uv-13 pro, the memory was corrupted, I am using the latest version of chirp, does anyone have a backup copy of this device?

Assuming that you downloaded from your radio before making any changes, CHIRP automatically creates a 'backup' of all successful downloads. There should be one of your radio in its original state prior to you making any changes. You can easily access the saved backups by clicking Show image backup location in the Help menu.

Actions #41

Updated by Cristofer Fuentealba 4 months ago

Jim Unroe wrote in #note-40:

Cristofer Fuentealba wrote in #note-39:

I had problems creating a backup copy of my uv-13 pro, the memory was corrupted, I am using the latest version of chirp, does anyone have a backup copy of this device?

Assuming that you downloaded from your radio before making any changes, CHIRP automatically creates a 'backup' of all successful downloads. There should be one of your radio in its original state prior to you making any changes. You can easily access the saved backups by clicking Show image backup location in the Help menu.

Dear, it was not possible to use this copy because it is corrupt, thank you very much in advance

Actions #42

Updated by Cristofer Fuentealba 4 months ago

Can someone share a backup copy of the Baofeng UV-13 Pro device?

Actions #43

Updated by Rot Ulet 4 months ago

Hi,

Purchased a UV-13 Pro V2 via Aliexpress with installed firmware 06.01.014. At first I was unable to read anything from the device then I remove the antenna and keep the device away from the USB cable and I been able to read 80% of the device memory. See the log attached.

How can I fix that issue?

Regards.

Actions #44

Updated by Jim Unroe 4 months ago

Cristofer Fuentealba wrote in #note-42:

Can someone share a backup copy of the Baofeng UV-13 Pro device?

I located my Baofeng UV-13 Pro V1 (still in its factory state) and captured a CHIRP Radio Images (*.img) file it.

Actions #45

Updated by Cristofer Fuentealba 4 months ago

Jim Unroe wrote in #note-44:

Cristofer Fuentealba wrote in #note-42:

Can someone share a backup copy of the Baofeng UV-13 Pro device?

I located my Baofeng UV-13 Pro V1 (still in its factory state) and captured a CHIRP Radio Images (*.img) file it.

Thanks for sharing, the equipment doesn't work, I think it's broken

Actions #46

Updated by Rot Ulet 4 months ago

Jim Unroe wrote in #note-44:

Cristofer Fuentealba wrote in #note-42:

Can someone share a backup copy of the Baofeng UV-13 Pro device?

I located my Baofeng UV-13 Pro V1 (still in its factory state) and captured a CHIRP Radio Images (*.img) file it.

Hi, I used this image on my V2: the device reboot but is unable to read properly the battery nor to change channel (VFO mode, locked to 666.500) nor talk.

Does someone have a Baofeng UV-13 Pro V2 image please?

Actions #47

Updated by James Dean 4 months ago

the same problem here, block vfo 666.500 , no channel, no batery, i had 014 firm upgrde to 013 and the same problem :-(

Actions #48

Updated by Cristofer Fuentealba 4 months ago

Bug #11167
There are already several of us with the same problem, I hope someone can help us solve it and not lose the equipment :(

Actions #49

Updated by Dan Smith 4 months ago

This issue is closed, let's please keep new discussion about this bug on #11167 so it's all in one place. Thanks!

Actions #50

Updated by Dan Smith 4 months ago

  • Related to Bug #11167: Trouble with UV-13Pro after upload added
Actions

Also available in: Atom PDF