Bug #6751


Chirp not seeing USB port.

Added by Christopher Bracken almost 5 years ago. Updated almost 5 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:
Chirp Version:
Model affected:
BaoFeng BF-F8HP
Debug Log:
I read the instructions above:


What is the behavior you are seeing?
I am using a desktop Mac…Purchased $20 cable from Baofeng…Plugged into new Baofeng BF-F8HP turned on radio attempted to “Clone”…received message “Error has occurred Radio did not respond”. First attempts offered 2 different ports…both giving same message. Now only being offered 1 port… (/dev/cu.Bluetooth-Incoming-Port) after download/install drivers as follows… Have downloaded/installed VDP “2.4.2 - Mac OS X 10.9 and above” several times…tried unloading/reloading drivers…tried D2XX drivers. All installs indicate that the install was successful but cloning still fails. Contacted FTDI…after having me do some command prompt checking they say it does not appear that they are installing and they don’t understand why drivers are not loading or working.still waiting to hear back from them. Contacted BaoFeng who had me reload drivers yet again and sent me here. It appears to be a driver USB issue to me (Novice).

  1. What is the behavior you were expecting?
    Was expecting Plug and Play as advertised by the cable provider.

  2. Can you reproduce the problem all the time?
    Every time!

  3. What are the steps required to reproduce the problem?
    Happens every time I try to Clone the radio.

  4. Is this specific to a certain radio model (driver) or something that you can reproduce with another radio?
    Happens the same with second identical radio.


debug.log (26 KB) debug.log Christopher Bracken, 04/26/2019 11:20 AM
Actions #1

Updated by Dan Smith almost 5 years ago

  • Status changed from New to Rejected

Yeah, that would be a driver issue, there's nothing chirp can do about it if the driver isn't showing up in /dev. Chirp talks to the driver, the driver talks to the radio.

Unfortunately, the state of USB-to-serial drivers on MacOS is the worst of all three platforms. The only options really are:

  1. Diagnose the issue yourself, find other driver, older or newer, or figure out what is/is not loading
  2. Get another cable from a vendor that will provide you real support
  3. Use a different operating system where USB-to-serial devices are better supported.

I know that's a crappy answer, but it's reality. I'm a Mac user myself and I share your pain. I do my development and programming on a different machine.


Also available in: Atom PDF