Project

General

Profile

Actions

Bug #10904

closed

Yaesu FT-8100R gets Unicode Strings not supported error downloading from radio

Added by William Curlew 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
10/19/2023
Due date:
% Done:

100%

Estimated time:
Chirp Version:
next
Model affected:
FT-8100R
Platform:
Windows
I read the instructions above:

Description

Have reset the radio using manufacturers instructions. When trying to read the radio, gets almost all the way through, then get error titled "Error communicating with radio". Detail of error message is "Unicode strings are not supported, Please encode to bytes '\x06'.

Have attached debug log.


Files

chirp_debug-xfvja8j3.txt (38 KB) chirp_debug-xfvja8j3.txt FT-8100 download unicode string error William Curlew, 10/19/2023 02:35 PM
ft8100.py (9 KB) ft8100.py 665cbc71 Dan Smith, 10/19/2023 02:52 PM
chirp_debug-6blbcq6j.txt (49 KB) chirp_debug-6blbcq6j.txt William Curlew, 10/19/2023 07:02 PM
ft8100.py (9.01 KB) ft8100.py 8f63f1d6 Dan Smith, 10/19/2023 07:09 PM
Yaesu_FT-8100_20231019_test.img (3.13 KB) Yaesu_FT-8100_20231019_test.img 2 channels of vhf added William Curlew, 10/19/2023 07:09 PM
Yaesu_FT-8100_20231019.img (3.13 KB) Yaesu_FT-8100_20231019.img from rest radio William Curlew, 10/19/2023 07:10 PM
ft8100.py (9.38 KB) ft8100.py 5cb064ba Dan Smith, 10/19/2023 08:05 PM
Yaesu_FT-8100_20231019_uhf.img (3.13 KB) Yaesu_FT-8100_20231019_uhf.img William Curlew, 10/19/2023 08:39 PM
chirp_debug-f1lrrfuc.txt (881 Bytes) chirp_debug-f1lrrfuc.txt William Curlew, 10/19/2023 08:54 PM
ft8100.py (9.33 KB) ft8100.py c87402d4 Dan Smith, 10/19/2023 09:11 PM
chirp_debug-5w0kh7_f.txt (49.7 KB) chirp_debug-5w0kh7_f.txt William Curlew, 10/19/2023 10:13 PM
Yaesu_FT-8100_20231020_with_UHF_adjusted_py_file.img (3.13 KB) Yaesu_FT-8100_20231020_with_UHF_adjusted_py_file.img William Curlew, 10/19/2023 10:15 PM
chirp_debug-gv_dd6ud.txt (62.5 KB) chirp_debug-gv_dd6ud.txt William Curlew, 10/20/2023 11:45 AM
Yaesu_FT-8100_20231020_split_ch_80.img (3.13 KB) Yaesu_FT-8100_20231020_split_ch_80.img William Curlew, 10/20/2023 11:46 AM
Yaesu_FT-8100_20231020_split_ch_80_vhf_uhf_copy_OK.img (3.13 KB) Yaesu_FT-8100_20231020_split_ch_80_vhf_uhf_copy_OK.img William Curlew, 10/20/2023 11:46 AM
ft8100.py (9.38 KB) ft8100.py 7fefe338 Dan Smith, 10/20/2023 01:08 PM
Yaesu_FT-8100_20231020_test with py for build.img (3.13 KB) Yaesu_FT-8100_20231020_test with py for build.img William Curlew, 10/20/2023 07:59 PM
chirp_debug-z04k3aya.txt (110 KB) chirp_debug-z04k3aya.txt William Curlew, 10/20/2023 08:00 PM
Actions #1

Updated by Dan Smith 6 months ago

The 8100 has not been converted to work with chirp-next yet. If you'll do some testing for me I can try to do it in the blind.

Actions #2

Updated by Dan Smith 6 months ago

Please try the attached module, using the instructions in LoadingTestModules. Please try download first. If that works, grab the image and be sure to save it in case upload fails as the radio will reset in that situation. Capture and attach the resulting debug log after testing, even if everything works.

Also, we don't have a test image for this radio, so if you have one from a previous version of chirp, that would be helpful. Or of course, if this works, with the current version.

Actions #3

Updated by William Curlew 6 months ago

Some progress. Was able to upload radio, but radio shows err on front panel afterwards. A brief red flash on the chirp screen before displaying the image received.

Cannot copy memory items from my 7900 image to the 8100 image.

Built a couple of mems by hand, cannot upload to radio. Get error message Failed to clone: Failed to communicate with the radio: block not ack'ed: b'\x06' and err on ft8100 again.

Also,after trying to download from radio, tried opening the saved 2 channel memory image and copying the 2 images to the download image, would not copy.

Actions #4

Updated by Dan Smith 6 months ago

Can you download and save a .img file to attach here please?

Actions #5

Updated by Dan Smith 6 months ago

Here's another module to try to address things in the latest debug log. I still want a .img file, captured either with the first module or this one.

Thanks for helping!

Actions #6

Updated by William Curlew 6 months ago

Here are the original that was downloaded, and the test one I tried to send to the radio.

Actions #7

Updated by Dan Smith 6 months ago

Thanks for the images. I found several other memory-editing issues in the driver with them and have fixed those up.

I gotta be honest with you, this driver is ancient and not well-maintained. Since we didn't have a test image to go with it, it wasn't running tests and thus there were a number of issues with it. Some of those I could resolve, but not all.

So here's an updated driver module to try which hopefully makes it a lot better. I'll be glad to take another debug log and report with this one if you can. Thanks for the help, I'm sure any other FT-8100 users out there appreciate it too :)

Actions #8

Updated by William Curlew 6 months ago

The last .py was much better. Can upload and download VHF no problem. However, UHF channels not so much. Tried to add a UHF repeater, and got error that the frequencies were out of ranger. Put the repeater into the radio and it uploaded OK, but try to copy and paste one or add by hand on the UHF side of Chirp and got the frequency error again.

Still, very good progress.

Actions #9

Updated by Dan Smith 6 months ago

Okay great. Issues with the UHF range are definitely of the class that I found using your image to run tests.

The driver calls the two sub devices "VHF" and "UHF" but it has one set of supported bands. I think maybe it should be "left" and "right". I think on this radio you can store VHF and UHF memories on either side, but the two sides of the radios have separate memories, is that right? Meaning if you store something in channel 1 on the left side, it's separate from channel 1 on the right side. Is that correct?

Actions #10

Updated by Dan Smith 6 months ago

  • File ft8100.py ft8100.py added
  • Status changed from New to In Progress
  • Assignee set to Dan Smith
  • Target version set to chirp-py3

Here's a fixed version where both sides have the same frequency ranges, renamed to "left" and "right". If my assumption above is correct, hopefully this is right. Let me know.

Thanks!

Actions #11

Updated by William Curlew 6 months ago

FYI, there is definitely a "left" vs "right" "bandedness" to the radio, however, it can be set up as VHF/UHF, VHF/VHF or UHF/UHF. There are two sets of distinct memories for the vhf vs the uhf channels.

It's 1AM here on the east coast. Ill look at this one more time then beddie bye. Thanks so much for your efforts tonight.

Bill

Actions #12

Updated by William Curlew 6 months ago

Nope, we lost ground. Can't copy into either VHF or UHF from my other radio image. Can enter UHF frequency manually however. Also, getting ERR on radio again when downloading into Chirp, and red flash at end of load.

Actions #13

Updated by Dan Smith 6 months ago

Okay I think you'll need to explain more. The manual is not super clear to me. It this a static thing you decide when you setup the radio for the first time? Or just a mode you put in it? Can memories from the left side be recalled on the right in V/V mode? That debug log has some other things to resolve, so thanks for that. I'll look at those after work today.

Actions #14

Updated by Dan Smith 6 months ago

Actually, I think maybe you loaded the wrong module for the last run and that's why you saw a regression in behavior. It also looks like you're loading modules manually. Can you use the process in LoadingTestModules? It helps to make sure you got the right one and logs information for me to be able to confirm exactly what you're running for each attempt.

Actions #15

Updated by William Curlew 6 months ago

Sorry. The FT8100 is usually set up as left/right VHF/UHF. You can change this dynamically using the buttons to VHF/VHF or UHF/UHF. You may only transmit on the "Main" channel, which you can select dynamically as well. At this point you can use the memory for that band on either side.

I have been saving the .py files in the same download area, and so they get re-numbers with the highest number being the latest pull. I was using the "load Module" menu item from FILE to bring them in. I will use the HELP method and retry the operations.

As a further comment, the FT8100 does support split mode (weird offsets) but only within the same BAND. (IE VHF TX must be in TX range, UHF TX must be in UHF range. The FT7900 does allow splits between VHF and UHF, but is not full duplex and the memories are common, no separated. In the image attached the memory 80 (145.800) was added manually to the radio with a split TX of 145.000. I modified the py you sent to enable the split choice on duplex and it did show up (but with weird offset). I saw the comment in the py module that this is not figured out yet, but thought I'd let you know. The py file I loaded this time is your original, no changes.

I was able to copy in a vhf and uhf channel from the FT7900, and they got sent correctly to the radio. This is excellent!

Bill
Bill

Actions #16

Updated by Dan Smith 6 months ago

Okay, I did some more reading of the manual last night and made some more changes. I think those all line up with your explanation. So, give this latest one a shot if you would. If this is good (or at least almost good) I'd like to get this merged tonight for a build tomorrow.

We can iterate on some of the details (like the split thing) in a separate effort. The radio's support for >1GHz also needs some attention.

Thanks!

Actions #17

Updated by Dan Smith 6 months ago

I'm going to go ahead and merge this so we don't hold up the build tomorrow. If it's not quite right, open another bug and we'll iterate from there and can also work on split and >1GHz if you're interested.

Actions #18

Updated by Dan Smith 6 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100
Actions #19

Updated by William Curlew 6 months ago

I agree this is working quite well. Funny that the mem 80 is coming in as split, when it is not a choice, hi hi.

Do you want me to open a new bug on supporting the split feature of the radio? I am definitely will to work with you more on this.

Thanks again for the excellent work, now I can much more simply program this beast.

Bill

Actions #20

Updated by Dan Smith 6 months ago

Yeah, if you don't mind, another bug for the split thing. What I'll ask for is if you can store two memories on the radio that are identical other than their split/offset and then capture an image for me to look at. That will let me compare the two and try to suss out the details. The original driver had some attempt at the split thing, but it wasn't complete, so hopefully it won't be a huge task.

Thanks for your help. Tomorrow's build will have the fix and the website front page will show the 8100 as supported in -next thanks to you!

Actions

Also available in: Atom PDF