Project

General

Profile

Actions

Bug #10702

closed

Quanshen UV-K5 - cannot disable TX on a channel - no OFF selection under Duplex

Added by Larry Rothman 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
07/04/2023
Due date:
% Done:

100%

Estimated time:
Chirp Version:
next
Model affected:
Quanshen UV-K5
Platform:
Windows
I read the instructions above:

Description

I have looked all over the website and done web searches but the only way I have found to disable TX on a channel is to select OFF in the Duplex column.
I just installed the 20230703 update and there is no OFF selection available in the Duplex field.
I was previously able to do this for my older Baofeng UV-5R on an older Chirp version but have not tried the Boafeng with the latest version.
If this is not an issue, how do you create receive-only channels? There are no instructions in the quickstart guide or anywhere on the Chirp website I can find.
Even the Air band channels do not show TX is disabled but it should.
Thanks for any help.
My radio FW is K5.2.01.23
I've attached the debug log and my codeplug.


Files

Quansheng_UV-K5_20230704.img (8.23 KB) Quansheng_UV-K5_20230704.img current codeplug Larry Rothman, 07/04/2023 06:50 AM
Quanshen codeplug - see ch130.cxf (81 KB) Quanshen codeplug - see ch130.cxf produced by Quanshen's CPS Larry Rothman, 07/04/2023 07:57 AM
Chirp_UV-K5_see ch130.img (8.18 KB) Chirp_UV-K5_see ch130.img produced by Chirp-next Larry Rothman, 07/04/2023 07:57 AM
UV-K5 manual 2023.02.17(2) small.pdf.zip (343 KB) UV-K5 manual 2023.02.17(2) small.pdf.zip UV-K5 manual from FCC website Larry Rothman, 07/04/2023 11:18 AM
uvk5.py (66.6 KB) uvk5.py UV-K5 driver with experimental TX disable feature Jacek Lipkowski SQ5BPF, 07/09/2023 02:21 PM

Related issues

Has duplicate Feature #10719: Disabling TX on UV-K5 with modded firmware.ClosedJacek Lipkowski SQ5BPF07/11/2023

Actions
Actions #1

Updated by Dan Smith 11 months ago

  • Assignee set to Jacek Lipkowski SQ5BPF
  • Target version set to chirp-py3

This is a feature each driver has to implement, which is why it's supported for the UV-5R. Does the radio support that if you program it manually? If so, it should be possible to make the driver do it.

Actions #2

Updated by Larry Rothman 11 months ago

I think I figured out how to turn off transmit on a given channel - but...
I can only do it on the Quanshen Windows programming application as it has separate fields for TX & RX frequencies.
Essentially, if I set the TX freq to one that the UV-K5 firmware has disabled transmitting on (like 50MHz) the radio will no longer transmit and will show "Disabled" when the PTT is pressed.

I tried this on the local weather station on my radio channel 130 and have attached my updated codeplugs - 1st from the Quanshen app and then I read the radio and save it using the July 3rd version of Chirp.

It would be a pain to have to calculate offset as Chirp shows for Ch130.
Is there a way to automate this with some kind of 'Disable' option maybe in the Duplex pulldown menu?

Of course, using any of the hacked firmware will screw this up, but then that's on those users - unless there is a more elegant way to disable TX.
I'm going to put in an enhancement request with Quanshen and see if they can add this to their next FW release.

I'm curious as to why there is only a single Freq column and not separate TX & RX columns now.

Thanks
Larry

Actions #3

Updated by Jacek Lipkowski SQ5BPF 11 months ago

Larry Rothman wrote in #note-2:

I think I figured out how to turn off transmit on a given channel - but...
I can only do it on the Quanshen Windows programming application as it has separate fields for TX & RX frequencies.
Essentially, if I set the TX freq to one that the UV-K5 firmware has disabled transmitting on (like 50MHz) the radio will no longer transmit and will show "Disabled" when the PTT is pressed.

Try this:

  • read from radio
  • enable support for modified firmware in chirp
  • program a channel with large negative offset so that the TX frequency is below 50MHz, for example program 145.500MHz , and -10MHz offset
  • write to radio

Try to see if it will transmit. If that works for you, then it can be supported within chirp easily.

VY 73

Jacek / SQ5BPF

Actions #4

Updated by Larry Rothman 11 months ago

Correction: I got the release doc for the modded 2.01.26 FW confused with the OEM release and I have the UN-MODDED OEM FW in my radio.

However - I can set the TX in the OEM CPS to TX 18MHz with no errors & then program the radio. But, when read back with the OEM CPS, it shows TX 50MHz.
So, I assume 50MHz is the lowest at this point for the current FW release and creating an explicit TX Disable pull-down option should probably just set the TX to 50MHz for now.

Thanks
Larry VE3LRI

Actions #5

Updated by Jacek Lipkowski SQ5BPF 11 months ago

Larry Rothman wrote in #note-4:

Correction: I got the release doc for the modded 2.01.26 FW confused with the OEM release and I have the UN-MODDED OEM FW in my radio.

But we're talking about chirp here:

  • Use chirp with an unmoded radio, and enable support for hacked firmware.
  • read from radio
  • set a memory channel at 145.500MHz, with -100MHz offset (so tx is at 45MHz, which is not supported by the radio).
  • upload to radio
  • try to transmit on this channel

Try and report the results here.

VY 73

Jacek / SQ5BPF

Actions #6

Updated by Larry Rothman 11 months ago

I tried that right after I submitted my last entry (with the correction).
Chirp produces an error pop-up stating the offset is out of the range of the radio (ie: below 50MHz)
If I use a neg offset of -95MHz, it takes it with out of range error.

So - it appears the lowest freq is 50MHz (for now) for which Quanshen has disabled TX in their OEM firmware releases.

it's a crude hack but if the OEM can release a new FW with a no-TX flag for each channel, that would be good.

Cheers,
Larry

Actions #7

Updated by Dan Smith 11 months ago

Jacek, is it possible that shift=0x03 means "use the offset as the tx frequency" ? That's a common pattern amongst radios that use an offset field. If so, perhaps shift=0x03 and offset=0 (i.e. TX on 0MHz) might be suitable for tx-inhibit?

Actions #8

Updated by Jacek Lipkowski SQ5BPF 11 months ago

Larry Rothman wrote in #note-6:

I tried that right after I submitted my last entry (with the correction).
Chirp produces an error pop-up stating the offset is out of the range of the radio (ie: below 50MHz)

So did you enable support for hacked firmware in chirp? This will remove the sanity check for out of band tx frequencies, and you should get no popup.

it's a crude hack but if the OEM can release a new FW with a no-TX flag for each channel, that would be good.

I think we might be able to do it in current firmware versions.

VY 73

Jacek / SQ5BPF

Actions #9

Updated by Jacek Lipkowski SQ5BPF 11 months ago

Dan Smith wrote in #note-7:

Jacek, is it possible that shift=0x03 means "use the offset as the tx frequency" ? That's a common pattern amongst radios that use an offset field. If so, perhaps shift=0x03 and offset=0 (i.e. TX on 0MHz) might be suitable for tx-inhibit?

I will try that too. Other possible ways are:

  • set a negative offset the same as the frequency, effectively setting TX of 0MHz

  • set an offset so that the TX frequency falls in the middle of the 640-850MHz range which is not supported by the chip.

VY 73

Jacek / SQ5BPF

Actions #10

Updated by Larry Rothman 11 months ago

When you check the box for "disable the limits for modified firmware" (mine isn't modified) it allows you to enter an offset in Chirp that will take you below 50MHz without an error.
If you input a neg offset value that takes you below 18.000MHz, the out of range error appears on Chirp.

So - for an Rx=162.4MHz, I entered an offset of -120MHz, programmed the radio and the menu setup on the radio showed -120MHz.
But - when I entered an offset of -144MHz in chirp, the radio still showed -120MHz in the menu setup.

I manually entered (MHz) -142, -143, -144 and finally -162.4 on the radio itself and it took them all and the TX was disabled for all entries.

Since I appeared to get strange results, I reset the radio and entered a freq of 162.4MHz manually and was able to add a -162.4MHz offset manually to disable TX on that channel without the radio complaining it was out of range.

I tried this for 444.425MHz with a -444.425MHz offset as well as 222.225MHz with a -222.225MHz offset and TX was disabled.

I also tried using a huge neg offset to go below 0HZ and the radio took an offset of -444.000 for the 222.225 freq! So there's no bounds checking in the firmware for the offset value.

I guess if you are able to bypass the freq restrictions for the codeplug, a negative offset of the receive freq will work since the UV-K5 manual states you can enter an offset of up to 999.9990MHz
And the solution was a lot simpler than I thought it would be.

Of course, this is for unmodified K5-2.01.26 OEM firmware.

I attached the manual I got from the FCCID website in case you needed it.

Actions #11

Updated by Jacek Lipkowski SQ5BPF 11 months ago

Try this driver. It will set - offset, and set offset = rx frequency, in effect setting a tx frequency of 0MHz.

It does work on 2.01.19 firmware. However it doesn't work of 2.01.26 modified firmware that disables tx limits. This is only very limited testing, please test it on all bands with different firmwares and report if it works.

To test it select Help -> Load modules from issue , enter this issue (10702), select the uvk5.py driver. In the channel duplex select "off".

VY 73

Jacek / SQ5BPF

Actions #12

Updated by Larry Rothman 11 months ago

I just tried the updated UV-K5 driver and it works as intended by creating a negative TX offset equal to the receive freq.
I tried this at 162.4, 220, 440 & 500 without any issues.
On the radio, these channels all show up in the settings as having a neg offset equal to the recv freq.
I currently have unmodified firmware 2.01.26 installed in my device.

As I mentioned earlier, there seems to be no bounds checking in the radio firmware and if you use a + offset that takes your TX freq above 600MHz, you will not see any error msg and the radio will TX at 600MHz, the upper freq limit for the fully open band-plan. A negative offset that is less than 0HZ just produces a 'DISABLE' msg on TX even if it wraps around to a value of -RCV freq.

Let me know if you need any more help with this.

Thanks for the great work, Jacek.

BTW, it's nice to know that firmware is not limited to upgrades only and that you can upgrade & downgrade to any version.
With that in mind, I played with some of the hacked FW and was able to TX/RX at 1GHz: RX sens=1uV but TX pwr was < -140dbm (of course).

73

Larry Rothman VE3LRI

Actions #13

Updated by Jacek Lipkowski SQ5BPF 11 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100
Actions #14

Updated by Dan Smith 11 months ago

  • Has duplicate Feature #10719: Disabling TX on UV-K5 with modded firmware. added
Actions

Also available in: Atom PDF