Project

General

Profile

Actions

Bug #8683

closed

Settings tab blank on Canadian model UV88

Added by Da Vee about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
01/15/2021
Due date:
% Done:

100%

Estimated time:
Chirp Version:
daily
Model affected:
TYT UV-88
Platform:
All
Debug Log:
I read the instructions above:

Description

This issue seems to be a TYT UV-88 issue but its affecting CHIRP.
I've debugged a bit and my findings are below.
Attached is the .img file after doing a "Reset All"
The debug.log is from reading this configuration.

Thanks for supporting this radio.

  1. What is the behavior you are seeing?
    Settings tab is empty.

  2. What is the behavior you were expecting?
    Settings populated

  3. Can you reproduce the problem all the time?
    Yes

  4. What are the steps required to reproduce the problem?
    Download from radio.
    View the Settings tab - It is empty.

  5. Is this specific to a certain radio model (driver) or something that you can reproduce with another radio?

  6. I'm sure it worked once before the radio was configured.

  7. Factory fw version was UV88_Eng_BQ1_30_20200629.hex

  8. All newer versions is showing this issue.

  9. Debug log shows an exception. Upon further investigation I found the region is 0xFF and not handled by the region enumeration.

I worked around this by
options = ['Unlocked', 'Unknown 1', 'Unknown 2', 'EU', 'US']

try:

rx = RadioSettingValueList(options, options[_settings2.region])
except Exception:

LOG.debug("Region setting of %i is invalid. Assuming Unlocked" % _settings2.region)
rx = RadioSettingValueList(options, options[0])*
rx.set_mutable(False)


Files

debug.log (262 KB) debug.log debug log Da Vee, 01/15/2021 06:54 PM
TYT_TH-UV88_20210115_Issue.img (8.82 KB) TYT_TH-UV88_20210115_Issue.img img file downloaded from this radio. Da Vee, 01/15/2021 06:54 PM
TYT_TH-UV88_20210217_issue.img (8.83 KB) TYT_TH-UV88_20210217_issue.img Tony Mattoni, 02/16/2021 11:45 PM
th_uv88.py (30.7 KB) th_uv88.py updated driver to use while waiting for patch to be accepted. Jim Unroe, 02/17/2021 04:47 PM
Actions #1

Updated by DJ kourampies about 3 years ago

Same problem on mine, bought on Aliexpress, don't know if its meant for a specific region.

Actions #2

Updated by Tony Mattoni about 3 years ago

CHIRP version daily-20201221 is working fine with TYT UV-88

Actions #3

Updated by Da Vee about 3 years ago

Tony Mattoni wrote:

CHIRP version daily-20201221 is working fine with TYT UV-88

You are correct. I just verified on daily-20201221 and its working

Actions #4

Updated by Da Vee about 3 years ago

Da Vee wrote:

Tony Mattoni wrote:

CHIRP version daily-20201221 is working fine with TYT UV-88

You are correct. I just verified on daily-20201221 and its working but not on latest.

Actions #5

Updated by Rudolph Gutzerhagen about 3 years ago

The assessment about the region code appears to be correct. The image indicates a hex FF is passed from the radio. Chirp-20201221 and Chirp-20210212 handle this differently based on region code.

Actions #6

Updated by Jim Unroe about 3 years ago

  • Status changed from New to In Progress
  • Assignee set to Jim Unroe
  • Target version set to chirp-legacy
  • Platform changed from Windows to All

DJ kourampies wrote:

Same problem on mine, bought on Aliexpress, don't know if its meant for a specific region.

Has your radio been "unlocked"?
Attach an image for testing.

Actions #7

Updated by Tony Mattoni about 3 years ago

Da Vee wrote:

Da Vee wrote:

Tony Mattoni wrote:

CHIRP version daily-20201221 is working fine with TYT UV-88

You are correct. I just verified on daily-20201221 and its working but not on latest.

Any later version than daily-20201221 is not working for me on Linux.

Actions #8

Updated by Jim Unroe about 3 years ago

Tony Mattoni wrote:

Da Vee wrote:

Da Vee wrote:

Tony Mattoni wrote:

CHIRP version daily-20201221 is working fine with TYT UV-88

You are correct. I just verified on daily-20201221 and its working but not on latest.

Any later version than daily-20201221 is not working for me on Linux.

Yes. That's when the setting was added that radios like your broke. I plan on trying to find some time to look at it today.

Jim KC9HI

Actions #9

Updated by Jim Unroe about 3 years ago

Tony Mattoni wrote:

Da Vee wrote:

Da Vee wrote:

Tony Mattoni wrote:

CHIRP version daily-20201221 is working fine with TYT UV-88

You are correct. I just verified on daily-20201221 and its working but not on latest.

Any later version than daily-20201221 is not working for me on Linux.

Thanks for adding your "image", Tony.

Jim KC9HI

Actions #10

Updated by Jim Unroe about 3 years ago

  • File th_uv88.py th_uv88.py added
  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

I just submitted a patch for approval. You can temporarily load the attached driver module to use while waiting for the patch to be accepted (or continue to use the older daily build).

Jim KC9HI

Actions #11

Updated by DJ kourampies about 3 years ago

Thanks for the patch, indeed it works fine now on mine (no idea about hardware version, latest 2021 firmware.

Actions #12

Updated by Bernhard Hailer about 3 years ago

  • Status changed from Resolved to Closed

Looks like this made it into the main branch.

Actions

Also available in: Atom PDF