Project

General

Profile

Actions

Bug #6971

closed

BTech GMRS V1 " not the amount of data we want"

Added by Paul Pearson over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/09/2019
Due date:
% Done:

0%

Estimated time:
Chirp Version:
daily
Model affected:
BTech GMRS V1
Platform:
MacOS
Debug Log:
I read the instructions above:

Description

Recently got a BTech GMRS V1. Connected to it with a known-good FTDI cable and was able to download and save the initial setup, per the CHIRP recommendations. I added a few local freqs and successfully uploaded to the radio. All good.
A few days later, I attempted to make a few changes to a GMRS repeater setting. When I attempted to upload to the radio (with the same previously successful cable), I got the message "Error reading data from radio: not the amount of data we want." Same result attempting to download.
A search for this issue with the GMRS V1 on the wiki attributed the issue to a cable problem, but this cable has been used successfully with this radio, as well as several other Baofeng and BTech radios.
Using a MacBook, OSX 10.7.5, CHIRP daily-20180606.
I understand the GMRS V1 driver is in beta. Just just thought you ought to know.
Thanks.

I am using the btech PC03 FTDI cable and still getting the issue listed above.


Related issues

Has duplicate Bug #6973: BTech GMRS V1 " not the amount of data we want"Closed08/09/2019

Actions
Actions #1

Updated by Erik D over 4 years ago

I am not sure about the mac, but on Ubuntu, I got that message when I had the wrong USB port selected on upload/download. For Ubuntu, I selected /dev/ttyUSB0 instead of the default per some recommendations I found via searches. It's possible that a similar change might work on the mac, but I'm not sure what the correct port would be for mac. I too was connected to a BTECH GMRS V1, but I have other radios as well and I select the same port for them as well -- which makes sense since this is really a host setting for which port the program should use to get to the device.

Actions #2

Updated by Bernhard Hailer about 4 years ago

  • Status changed from New to Feedback
  • Assignee deleted (Paul Pearson)

(See feedback above)

Actions #3

Updated by Bernhard Hailer almost 4 years ago

Have you been able to resolve this on your own since you submitted this?
Have you tried with a recent version since you submitted this?
If you haven't, and if you're still having this issue, please refer to the Wiki "How To Report Issues" and provide a debug log. Thanks!

Actions #4

Updated by Bernhard Hailer over 3 years ago

  • Status changed from Feedback to Closed

No more traffic on this ticket. -
You may want to read through the Wiki: perhaps you have an operating system caused issue.
CableGuide
CableGuide FTDI OEM Cables
[RTSystemsCablesAndMavericks]
If there's no solution to be found in any of them, please read: How To Report Issues and provide a debug log. Thank you!
MacOS notes: this OS is apparently very picky about USB to Serial cables. From what I heard, only (genuine) FTDI-based cables can be made work.
You must have the KK7DS Python runtime for Mac OSX installed.
Also see MacOS Tips!

Actions

Also available in: Atom PDF