Bug #5349


Write Error Icom IC-T70A w/ MacOS High Sierra

Added by Eric Struble over 6 years ago. Updated about 4 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:
Chirp Version:
Model affected:
Icom IC-T70A
Debug Log:
I read the instructions above:


Installed latest build (20171104) and tried to re-flash memory with correct contents.

Was able to read and edit memory contents without any problem. But, when I tried to re-write the contents back into the radio; it starts to write, the progress bar moves to the right like normal and the radio displays cloning info. The write appears to complete but then the radio displays Clone Error and an error message pops up on the screen saying that there was a write error. At this point all memory contents of the radio has been erased. The only way I could fix the problem was to boot up a Windows system and re-write the exact same file that I was using on the Mac into the radio. Everything worked fine after that. I am using a GoGear FTDI USB to RS-232 adaptor. I tried to re-install the latest drivers for the adapter, no change. Note: in my environment, Chirp will not work with a Prolific USB to RS-232 adaptor.

The previous version I was using was a build from July and macOS Sierra, which was working just fine. I did not try to run it with the older build and High Sierra (assumed that it would port over from Sierra just fine).

Actions #1

Updated by Tom Hayward over 6 years ago

  • Subject changed from Bricked Icom IC-T70A w/ MacOS High Sierra to Write Error Icom IC-T70A w/ MacOS High Sierra

Everything worked fine after that.

Changed title for clarity.

Chirp code is identical on all operating systems. What differs between operating systems is the USB serial drivers. It sounds like the driver you have installed for your cable in OS X is buggy. You might check for updates from the manufacturer.

Actions #2

Updated by Tom Hayward over 6 years ago

  • Status changed from New to Feedback
Actions #3

Updated by Bernhard Hailer about 4 years ago

  • Status changed from Feedback to Closed
  • Target version set to chirp-legacy
  • Chirp Version changed from 0.4.0 to daily
  • Model affected changed from IC-T70A to Icom IC-T70A

No more traffic on this ticket.


Also available in: Atom PDF