New Model #5109


Radioddity R1 (minor change)

Added by Christian Coors almost 7 years ago. Updated about 4 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:
Equipment Loan/Gift Offered:
I read the instructions above:



I own a Radioddity R1, which seems to be another rebrand of the Retevis R22 radio. Unfortunately, it sends a different identification string. But after patching chirpw to accept the other identifiaction string everything seems to work.

Before patching I got this log message for the identification string:

chirp.drivers.retevis_rt22 - DEBUG: 000: 50 33 32 b2 37 33 f8 ff   P32.73..

Which looks suspiciously like the "P32073", that is expected ( If anyone could add support for the Radioddity R1, that would be great. I would do it, but I'm not a Python developer and I am not familiar with Mercurial.


retevis_rt22(r1_test).py (19.1 KB) retevis_rt22(r1_test).py Jim Unroe, 08/26/2017 07:12 PM
Actions #1

Updated by Jim Unroe over 6 years ago

Hi Christian,

Let's see if that is the only difference. Try this test driver module. Here's how...

1 Download the attached test driver module file and save it to where you keep you CHIRP Radio Images (*.img) files
2 Load CHIRP
3 Click "Menu" and enable "Enable Developer Function"
4 Click "File"
5 Click "Load Module" and then locate and load the file saved in step 1
6 Download from your R1.

If you get a successful download, save an unedited copy to a safe place as a backup. Save a second time as your working copy. Now you can try and upload and also validate that the settings are the same.

This driver does not permanently change your CHIRP installation. Every time you load CHIRP, you will have to load this driver module before you can download from or upload to your R1.


Actions #2

Updated by Christian Coors over 6 years ago

Hi Jim,

Thanks, I tried that and it mostly works! I tried all permutations of channel settings and found some discrepancies after uploading and downloading:

If I set Duplex to 'split', the radio sets it to '(None)' and forgets about the offset frequency

If I set Duplex to 'off', the radio sets it to '+' with an offset frequency of 1233.166650

All the other settings seem to work fine.

Christian, DO5NQ

Actions #3

Updated by Bernhard Hailer about 4 years ago

  • Status changed from New to Closed
  • Target version set to chirp-legacy

The functionalify for the RT1 has been added.
If there are further issues, please open a new ticket. Thanks!


Also available in: Atom PDF