Project

General

Profile

Actions

Bug #4719

open

Wouxun KG-UV8D PL/DPL Decode

Added by Phil Lichtenberger about 7 years ago. Updated about 2 months ago.

Status:
Feedback
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
04/09/2017
Due date:
% Done:

0%

Estimated time:
Chirp Version:
daily
Model affected:
Wouxun KG-UV8D
Platform:
All
Debug Log:
I read the instructions above:
Yes

Description

Hi,
I've discovered an issue with Chirp and the Wouxun KG-UV8D. I'm using the "CHIRP daily-20170406" release at this time.

The issue was discovered when I tried to program in a channel that did not use PL/DPL Decoding. The radio still showed a "QT" on the display, which means that the channel required a decode tone. When I would manually enter the channel to edit it, the PL setting was set to none, and when I exited out, the "QT" was removed from the display.

I then wrote the FRS channels to the radio with no tone, and read it back with the Wouxun software. Wouxun's software shows an invalid tone is saved to the radio from Chirp. I then cleaned up the file and wrote it back to the radio and read it with CHIRP again. I've attached all files.

All FRS channels in the file should have no PL Decode tone, except for the memory channel that is labelled as having a tone.

Thanks


Files

FRS Write.img (32 KB) FRS Write.img Writting FRS Channels to the Wouxon with no PL Decode Phil Lichtenberger, 04/09/2017 01:30 PM
FRS Read.img (32 KB) FRS Read.img Reading the CHIRP programmed radio that should have no PL Decode Phil Lichtenberger, 04/09/2017 01:30 PM
Read from Chirp.kg (32 KB) Read from Chirp.kg Reading the CHIRP Programmed radio with Wouxun's Software Phil Lichtenberger, 04/09/2017 01:30 PM
Wouxun SW Fix.kg (32 KB) Wouxun SW Fix.kg Correcting the file with Wouxun's software so that no PL is required for Decode Phil Lichtenberger, 04/09/2017 01:30 PM
FRS Read after Wouxon Write.img (32 KB) FRS Read after Wouxon Write.img CHIRP reading the radio after being written by Wouxun's software Phil Lichtenberger, 04/09/2017 01:30 PM
kguv8d.py (38.7 KB) kguv8d.py Fixes Tone Decoding Mel Terechenok, 02/21/2024 02:42 PM

Related issues

Related to Bug #4425: KG-UV8D Inverted DCS IssueFeedback01/18/2017

Actions
Related to Bug #5483: Wouxun UV-8D download with DCS receive filter always onNew01/06/2018

Actions
Related to Bug #9081: AR-F8 (Wouxun KG-UV8D) digital tone errorNew05/20/2021

Actions
Actions #1

Updated by Nathan Kennedy almost 7 years ago

I am having this issue as well on the latest chirp daily build.

I would be happy to test any changes that would help fix this issue.

Actions #2

Updated by Bernhard Hailer almost 4 years ago

  • Status changed from New to Feedback
  • Target version set to chirp-legacy
  • Chirp Version changed from 0.4.0 to daily
  • Platform changed from Windows to All

Is this still an issue with the current daily builds? Thanks.

Actions #3

Updated by John Leyendecker almost 4 years ago

Bernhard Hailer wrote:

Is this still an issue with the current daily builds? Thanks.

I'm using the latest version (20200622) and this is still a problem. In addition, if I use the factory software (which is horrible in most respects) to read the radio after writing with Chirp 20200622 the tones are all messed up. I went back to Chirp version 20190703 and the tones were correct in the radio and they were correct when I read the radio with the factory software.

I hope that helps

Actions #4

Updated by Mel Terechenok about 2 months ago

Try this test driver.
I believe it corrects all the issues with the UV8D Tones.

How to load test drivers

Actions

Also available in: Atom PDF