Bug #1911


.img file with matching Firmware still causes CHIRP to crash and radios to not work

Added by Chris Spencer over 9 years ago. Updated over 4 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:
1.00 h
Chirp Version:
Model affected:
Baofeng UV-5R
Debug Log:
I read the instructions above:



I work for a national youth organization giving teenagers the opportunity to have mountain biking as their high school sport. We have just started using UV-5R and UV-5RA radios to aid in our risk management and EMS response at races. While I've successfully troubleshot the rest of our eighty radios, I am having trouble with one last set of thirty radios.

You can learn more about our organization if you're interested by following this link:

Here's the list of things I have done:

  1. Using Chirp 0.4.0. I programmed 30 BaoFeng UV-5R radios with a file that wasn't written for the correct firmware
  2. radios would only receive with Moni button pressed.
  3. to find the correct file we reset a radio, uploaded it to chirp and found the following version: Firmware Message 1: N5R-20 Firmware Message 2: BFB297
  4. we went to to download the corresponding "factory" and "reset" files, but found those files crashed chirp and didn't program the radios.

Has anyone else had a similar issue? Are we missing some sort of firmware understanding? Thank you.


P.S. I attached the file downloaded from the reset radio.


GA Radio 1.img (6.32 KB) GA Radio 1.img Chris Spencer, 09/15/2014 11:12 AM
An error has occurred.jpg (48.8 KB) An error has occurred.jpg Jim Unroe, 09/15/2014 03:30 PM
fault.jpg (95.4 KB) fault.jpg fault message Jakob Bjarnason, 09/16/2014 04:18 PM
Actions #1

Updated by Jim Unroe over 9 years ago


First, if you have any Baofeng radios with N5R-20 or N5R-30 firmware, you must be using a CHIRP Daily Build newer than 20140714. This prevents you from uploading a saved .img file from a previous firmware version. But since you already have done this, you need to use the CHIRP Daily-20140714 or older (v0.4.0 should work) to perform the recovery before upgrading to the latest daily build.

Which .img file are you trying to upload? You should be using the "N5R-20(factory).img" or "N5R-20.img" to perform the recovery.

If you are downloading any other .img file and uploading it to these radios with N5R-20 firmware, you will get the "An error has occured" message (see attached image). This is not a crash! It is just an informational message to let you know that a part of the upload had to be skipped because of the difference between firmware versions. It would be the wrong firmware version to recover these radios, though. If you upload one the the .img files specified above, you won't see this "error" and your receive will be restored.

Once you get the "N5R-20(factory).img" file loaded to all of these radios, then it is very important that you install the latest CHIRP Daily Build and use it instead of V0.4.0.

Let me know if this helps?


Actions #2

Updated by Jakob Bjarnason over 9 years ago


I have the same/similar problem.

I started with copying old .img to my new UV-5R radios with the new N5R-20 firmware.

After that I found the recovery process, downloaded the Chirp Daily-20140714 and "N5R-20.img" and tried to upload it.

I tried both N5R-20.img and also N5R-20(factory) but nothing works.

Actions #3

Updated by Jim Unroe over 9 years ago

OK. I am going to try to explain this one more time. This is not a crash. Please read the message. The part of the .img file that is needed to "recover" your radio has been uploaded successfully. It is only the "other settings" that did not get transferred. They are not needed for the recovery process. Once this operation has been completed, upgrade to the latest CHIRP daily build and you should be good.


Actions #4

Updated by Jim Unroe over 9 years ago

OK. I see the issue. The older CHIRP daily build reads 2 too many characters for the firmware version. These extra characters don't match and causes CHIRP to report the error. Ignore the error, the radio has been recovered. Then update to the latest CHIRP daily build. It not only has been updated to prevent cross loading of the pre-N5R-20 .img files into radio with N5R-20 firmware, it has also been updated to not read the 2 extra characters.


Actions #5

Updated by Jakob Bjarnason over 9 years ago

Ok this worked!! :)

I never tried to upload from the newest chirp daily build because I thought the recovery didn't work when the fault was still in after uploading from the 14072014 daily build.

Next time I know that I need to finish the whole recovery process

Best regards
Jakob B.

Actions #6

Updated by Jim Unroe over 9 years ago

I'm glad you got it.

I had Miklor John update the "recovery procedure" to explain that this error as a possibility and to just continue if it appears.


Actions #7

Updated by Bernhard Hailer over 4 years ago

  • Status changed from Feedback to Closed
  • Priority changed from High to Normal
  • Target version set to chirp-legacy
  • Chirp Version changed from 0.4.0 to daily
  • Model affected changed from UV-5R to Baofeng UV-5R



Also available in: Atom PDF