Project

General

Profile

Actions

New Model #11067

closed

We Need Talkpod A36Plus 8W Version

Added by Roy Wang 3 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
01/08/2024
Due date:
% Done:

100%

Estimated time:
Equipment Loan/Gift Offered:
I read the instructions above:
Yes

Description

I currently own a Talkpod A36Plus 8W version, but I've noticed that CHiRP doesn't offer programming for the 8W version of the A36plus. I thought Talkpod had communicated with you about this, but it seems they don't know how to communicate with you, so I am now bringing this issue to your attention.


Files

Actions #1

Updated by Jim Unroe 3 months ago

Have you tried the current A36Plus selection? What doesn't work. Attach the debug log. If you can't get a suitable debug.log from the current selection, then there is little hope that developing support will be possible without a volunteer developer such as myself having physical access to a A36Plus 8W radio and the official OEM software. It is possible that someone else might, but I won't be purchasing one to do the development.

Actions #2

Updated by Roy Wang 3 months ago

Thank you for reaching out with your suggestion,Jim. I haven't yet tried the current A36Plus selection in CHIRP, but I'll definitely give it a go and see how it works. The main issue I've encountered is when connecting the Talkpod A36plus 8W version with the provided programming cable to CHIRP, it shows an error saying "Radio Returned Unknown Identification Strings."

I'll work on gathering a suitable debug log based on the current selection and share it for further analysis. I understand the challenge without having physical access to the A36Plus 8W radio and the OEM software. I appreciate your advice and will keep you updated on any progress.

Actions #3

Updated by Jim Unroe 3 months ago

Roy Wang wrote in #note-2:

The main issue I've encountered is when connecting the Talkpod A36plus 8W version with the provided programming cable to CHIRP, it shows an error saying "Radio Returned Unknown Identification Strings."

Which is what I would expect. The debug.log will contain the information that would be necessary to add it.

Actions #4

Updated by Mike Gassman 3 months ago

I’m having the same issue. I believe Bug #11078 has a debug log attached.
Thank you for your work to get this resolved.

Actions #5

Updated by Jim Unroe 3 months ago

Mike Gassman wrote in #note-4:

I’m having the same issue. I believe Bug #11078 has a debug log attached.
Thank you for your work to get this resolved.

Thanks for the heads up, Mike. I have the logs and will be doing all of the development here on this ticket.

Actions #6

Updated by Jim Unroe 3 months ago

Please provide the details from the VERSION menu of your radio. Also, would someone with this radio please make a copy of this list and update it to match the menus of your radio? Thanks.

Actions #7

Updated by Mike Gassman 3 months ago

Thanks Jim.

The new model has 55 items in the menu vs. 54 in the earlier model, and one menu item location has changed.

  • In the earlier model, CH-NAME was at menu location 19; in the new model it has been moved to menu location 13 (the other menu items between those slots moved accordingly).
  • In the new model, a new menu item ANI FUNCTION was added as menu item 51 (options are OFF, ON); the items above that moved up one slot.

The Version info for the earlier model is
TalkpodA36Plus
Firmware:V1.24

The Version info for the new model is
A36Plus 10W
Firmware:V1.4

Actions #8

Updated by Mike Gassman 3 months ago

Jim,

Was that the information you needed?

Mike

Actions #9

Updated by Jim Unroe 3 months ago

Mike Gassman wrote in #note-8:

Jim,

Was that the information you needed?

Mike

Probably, but not exactly what I am looking for. I am waiting on someone to return an edited version of my menu list that exactly matches this new radio.

Jim

Actions #10

Updated by Mike Gassman 3 months ago

Jim,

I'm sorry, I misunderstood.

Here is my effort at the edited menu list.

Regards,

Mike

Actions #11

Updated by Jim Unroe 3 months ago

Based on menu list supplied by Mike, the settings appear to be largely the same.

Looking at the TalkPod website's download page, it looks like they are keeping the firmware for the 5w models separate from the 8w models. So it would seem to be a good idea to keep the models separate in CHIRP.

I have attached a test driver module to use for testing the downloads from the 8w version (Vendor: Talkpod / Model: A36Plus_8w). The ability to upload is currently disabled . Please test to see if downloading works. If it does, do your best to compare the radio's settings to those in CHIRP to see that they are the same and/or make sense. Report any issues and/or successes.

How to use the test driver module: LoadingTestModules

Actions #12

Updated by Mike Gassman 3 months ago

Jim,

I tried to load the test driver module but got the error message "No modules found in issue 11067"

Mike

Actions #13

Updated by Jim Unroe 3 months ago

Mike Gassman wrote in #note-12:

Jim,

I tried to load the test driver module but got the error message "No modules found in issue 11067"

Mike

This is a common problem. I select the file to add but somehow something happens (probably something I do) causes it to be removed. I can see it selected as I type this so hopefully it will be included with this note.

Actions #14

Updated by Mike Gassman 3 months ago

Jim,

It downloaded fine. Looks like you’ve got a workable solution.

I have never used it and don’t know what the ANI function does. However, on the 8w radio, there is an ANI FUNCTION on/OFF item and an ANI NAME field (which is empty). On the Chirp Settings page, there is just an ANI item and it is set to 16.

Thanks,

Mike

Actions #15

Updated by Jim Unroe 3 months ago

Mike Gassman wrote in #note-14:

Jim,

It downloaded fine. Looks like you’ve got a workable solution.

I have never used it and don’t know what the ANI function does. However, on the 8w radio, there is an ANI FUNCTION on/OFF item and an ANI NAME field (which is empty). On the Chirp Settings page, there is just an ANI item and it is set to 16.

Thanks,

Mike

I forgot to request that you attache a *.img file from your radio so I can review it prior to enabling uploading. Thanks.

Actions #17

Updated by Jim Unroe 3 months ago

Mike Gassman wrote in #note-16:

Jim,

Here's the .img file.

Mike

Thanks Mike. I don't see anything that jumps out at me so here is the latest file with uploads enabled. Let's test it out over the next few days to see how it goes.

Actions #18

Updated by Mike Gassman 3 months ago

Jim,

Will do. I’ll let you know if I run into anything.

Thanks,

Mike

Actions #19

Updated by Mike Gassman 2 months ago

Mike Gassman wrote in #note-18:

Jim,

Will do. I’ll let you know if I run into anything.

Thanks,

Mike

Seems to be running okay. Thanks.

Actions #20

Updated by Jim Unroe 2 months ago

Mike Gassman wrote in #note-19:

Mike Gassman wrote in #note-18:

Jim,

Will do. I’ll let you know if I run into anything.

Thanks,

Mike

Seems to be running okay. Thanks.

Thanks for the feedback. I will try to submit a patch today for including it in CHIRP.

Actions #21

Updated by Jim Unroe 2 months ago

  • Status changed from New to In Progress
  • Assignee set to Jim Unroe
  • Target version set to chirp-py3
  • % Done changed from 0 to 100

Patch submitted. Support should be in the next CHIRP build following acceptance.

Actions #22

Updated by Anonymous 2 months ago

  • Status changed from In Progress to Closed
Actions #23

Updated by Mike Gassman about 2 months ago

Thank you.

Actions

Also available in: Atom PDF