Project

General

Profile

Actions

New Model #11046

closed

Baofeng M-5R

Added by Zoltan Unyatinszki 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
12/28/2023
Due date:
% Done:

100%

Estimated time:
Equipment Loan/Gift Offered:
No
I read the instructions above:
Yes

Description

Hi all!
I can't get my new radio to use Chirp communication... (Win10 Enterprise, Prolific2303 cable)
Older UV-5R control test OK.
Will you support the M-5R radio later?
(Congratulations on this development!!)


Files

chirp_comm_error.PNG (15.1 KB) chirp_comm_error.PNG Zoltan Unyatinszki, 12/28/2023 07:50 AM
chirp_setting.PNG (13.2 KB) chirp_setting.PNG Zoltan Unyatinszki, 12/28/2023 07:50 AM
chirp_version.PNG (11.6 KB) chirp_version.PNG Zoltan Unyatinszki, 12/28/2023 07:50 AM
debug.log (2.99 KB) debug.log Zoltan Unyatinszki, 12/28/2023 07:50 AM
Baofeng_UV-5R_20231229T160651.img (6.49 KB) Baofeng_UV-5R_20231229T160651.img Zoltan Unyatinszki, 12/29/2023 08:04 AM
chirp.config (545 Bytes) chirp.config Zoltan Unyatinszki, 12/29/2023 08:04 AM
debug.log (194 KB) debug.log Zoltan Unyatinszki, 12/29/2023 08:04 AM
baofeng_wp970i_uv5rx.py (32.7 KB) baofeng_wp970i_uv5rx.py Use Vendor: Baofeng / Model: UV-5RX Jim Unroe, 01/13/2024 05:33 PM
chirp.config (967 Bytes) chirp.config Zoltan Unyatinszki, 01/14/2024 07:48 AM
debug.log (6.43 KB) debug.log Zoltan Unyatinszki, 01/14/2024 07:48 AM
picture.PNG (20.8 KB) picture.PNG Zoltan Unyatinszki, 01/14/2024 07:48 AM
Baofeng_UV-5RX_20240114.img (8.18 KB) Baofeng_UV-5RX_20240114.img Zoltan Unyatinszki, 01/14/2024 10:33 AM
chirp.config (1.52 KB) chirp.config Zoltan Unyatinszki, 01/14/2024 10:33 AM
debug.log (93.7 KB) debug.log Zoltan Unyatinszki, 01/14/2024 10:33 AM
baofeng_wp970i_uv5rx.py (32.8 KB) baofeng_wp970i_uv5rx.py added 350-390 MHz range Jim Unroe, 01/14/2024 11:50 AM
chirp.config (1.67 KB) chirp.config Zoltan Unyatinszki, 01/16/2024 02:10 AM
Baofeng_UV-5RX_20240116.img (8.18 KB) Baofeng_UV-5RX_20240116.img Zoltan Unyatinszki, 01/16/2024 02:10 AM
debug.log (101 KB) debug.log Zoltan Unyatinszki, 01/16/2024 02:10 AM
baofeng_wp970i_uv5rx.py (32.8 KB) baofeng_wp970i_uv5rx.py Use Vendor: Baofeng / Model: 5RX Jim Unroe, 01/16/2024 01:19 PM
Actions #1

Updated by Jim Unroe 4 months ago

The M-5R radio is not supported. This is the cause of the communications error when using the UV-5R model selection. Do you know where the factory software for the M-5R can be downloaded?

Actions #2

Updated by Zoltan Unyatinszki 4 months ago

Jim Unroe wrote in #note-1:

The M-5R radio is not supported. This is the cause of the communications error when using the UV-5R model selection. Do you know where the factory software for the M-5R can be downloaded?

Hi Jim!
Thanks for the answer!
We managed to communicate with the radio! There were so many changes that it was connected to COM5...
I am attaching the img log and config files. Maybe you will find valuable information for development in it.
(It has been working with Chirp since writing/reading happened on the radio!)
Please let me know if I can help you with anything.
HA8LNU Zoli

Actions #3

Updated by Philip Childs 4 months ago

The UV-S9X3 is the closest but it does allow the frequency ranges to be set.

Actions #4

Updated by Florian R 3 months ago

Will support be added in the future?

Actions #5

Updated by Jim Unroe 3 months ago

Zoltan Unyatinszki wrote in #note-2:

Jim Unroe wrote in #note-1:

The M-5R radio is not supported. This is the cause of the communications error when using the UV-5R model selection. Do you know where the factory software for the M-5R can be downloaded?

Hi Jim!
Thanks for the answer!
We managed to communicate with the radio! There were so many changes that it was connected to COM5...
I am attaching the img log and config files. Maybe you will find valuable information for development in it.
(It has been working with Chirp since writing/reading happened on the radio!)
Please let me know if I can help you with anything.
HA8LNU Zoli

Great. You can help by making a list of the known differences. For example:

  • How many TX power levels are supported (2 or 3)?
  • How many bands are supported?
  • What are the frequency ranges of each band?
  • etc
Actions #6

Updated by Jim Unroe 3 months ago

My Baofeng UV-5RX arrived today. Attached is a test driver module for the Baofeng UV-5RX. It should also work for the 5RX, M-5R and other UV-5R like models that support the 108-136 MHz (air), 136-174 MHz (vhf), 200-260 MHz (vhf2) and 400-520 MHz (uhf) bands.

How to use test driver modules: LoadingTestModules

Please provide feedback. It would be helpful if someone would attach an image downloaded from an M-5R or similar model radio. Thanks in advance.

Actions #7

Updated by Zoltan Unyatinszki 3 months ago

Zoltan Unyatinszki wrote:

Hi all!
I can't get my new radio to use Chirp communication... (Win10 Enterprise, Prolific2303 cable)
Older UV-5R control test OK.
Will you support the M-5R radio later?
(Congratulations on this development!!)

img file cannot be saved...
Have a nice day!

Actions #8

Updated by Jim Unroe 3 months ago

Zoltan Unyatinszki wrote in #note-7:

img file cannot be saved...
Have a nice day!

How did you download and save the image that you attached above. I am able do download from my radio using and of the following...

  • Baofeng GT-5R
  • Baofeng UV-5R
  • Baofeng UV-S9X3
  • Radioddity UV-5RX3

The Baofeng UV-S9X3 support matched the closest so all I had to do was to update the valid bands to match. If you got one of the above listed models to work, then the new UV-5RX selection must work unless you have a programming cable issue.

Actions #9

Updated by Zoltan Unyatinszki 3 months ago

Jim Unroe wrote in #note-8:

Zoltan Unyatinszki wrote in #note-7:

img file cannot be saved...
Have a nice day!

How did you download and save the image that you attached above. I am able do download from my radio using and of the following...

  • Baofeng GT-5R
  • Baofeng UV-5R
  • Baofeng UV-S9X3
  • Radioddity UV-5RX3

The Baofeng UV-S9X3 support matched the closest so all I had to do was to update the valid bands to match. If you got one of the above listed models to work, then the new UV-5RX selection must work unless you have a programming cable issue.

Hi Jim!
The devil hid in my laptop...
I went to my HAM corner, did what you asked again on the desktop PC, I am attaching the files.

Actions #10

Updated by Jim Unroe 3 months ago

Zoltan Unyatinszki wrote in #note-9:

Hi Jim!
The devil hid in my laptop...
I went to my HAM corner, did what you asked again on the desktop PC, I am attaching the files.

Thank you for the image. It further convinces me that the (UV-)5RX and M-5R are the same radios. Because of this I was able to discover that my radio has support for the 350-390 MHz range (RX only).

Would you validate the bands in your radio? Switch to VFO mode. Set STEP to 2.5K. Key in the lowest frequency for the band. Finally tap the v key. This should wrap the VFO display around to the highest frequency for the band. Repeat for all 5 bands.

AIR: 108.00000, 135.99750
VHF: 136.00000, 173.99750
220: 200.00000, 259.99750
350: 350.00000, 389.99750
UHF: 400.00000, 519.99750

I have attached the updated test driver module which includes support for the 350-390 MHz range.

Actions #11

Updated by Zoltan Unyatinszki 3 months ago

Jim Unroe wrote in #note-10:

Zoltan Unyatinszki wrote in #note-9:

Hi Jim!
The devil hid in my laptop...
I went to my HAM corner, did what you asked again on the desktop PC, I am attaching the files.

Thank you for the image. It further convinces me that the (UV-)5RX and M-5R are the same radios. Because of this I was able to discover that my radio has support for the 350-390 MHz range (RX only).

Would you validate the bands in your radio? Switch to VFO mode. Set STEP to 2.5K. Key in the lowest frequency for the band. Finally tap the v key. This should wrap the VFO display around to the highest frequency for the band. Repeat for all 5 bands.

AIR: 108.00000, 135.99750
VHF: 136.00000, 173.99750
220: 200.00000, 259.99750
350: 350.00000, 389.99750
UHF: 400.00000, 519.99750

I have attached the updated test driver module which includes support for the 350-390 MHz range.

Hi Jim!

I have completed the requested settings. Yes, 350: 350.00000, 389.99750 also works (RX only).
I am attaching the fillets after the adjustment.
best regards!

Actions #12

Updated by Jim Unroe 3 months ago

A patch has been submitted. Support should be in the CHIRP-next build following acceptance.

I did have to make one 'style' change so I have attached the new driver to this issue. As a reminder, I have changed the model selection to be "5RX" (which matches the labeling on the UV-5RX that I bought). There will also be an entry in the CHIRP Supported Models List that will tell M-5R owners to use Baofeng / 5RX.

Actions #13

Updated by Jim Unroe 3 months ago

  • Status changed from In Progress to Closed

Support will be in the next CHIRP-next build.

Actions

Also available in: Atom PDF